Downtime in Asset Manager SA Service

Incident Report for Jisr HR

Resolved

The incident has been resolved
Posted Oct 08, 2025 - 13:21 UTC

Investigating

We are investigating an issue in the Asset Manager SA Service
Posted Oct 08, 2025 - 13:14 UTC
This incident affected: Asset Manger Service.