Downtime in Web API SA

Incident Report for Jisr HR

Resolved

The incident has been resolved
Posted Oct 06, 2025 - 06:26 UTC

Investigating

We are investigating an issue in the Web API SA
Posted Oct 06, 2025 - 06:26 UTC
This incident affected: Web API.