Downtime in ATS AWS Service

Incident Report for Jisr HR

Resolved

The incident has been resolved
Posted Oct 12, 2025 - 02:34 UTC

Investigating

We are investigating an issue in the ATS AWS Service
Posted Oct 12, 2025 - 02:33 UTC
This incident affected: ATS Service.