Mobile API AWS Investigating

Incident Report for Jisr HR

Resolved

The incident has been resolved
Posted Mar 02, 2026 - 11:49 UTC

Investigating

We are investigating an issue in the Mobile API AWS
Posted Mar 02, 2026 - 10:55 UTC
This incident affected: Mobile API.